Mediaportal MP-TVSeries Re-Import Bugfix

This is largely for my own records, but someone might find it useful:

Manual Solution for problems re-importing after delete. This bug occurs with v2.6.0 when you delete a show from your database and then attempt to reimport it. It appears to detect the files, but doesn’t identify them as needing to be imported. This is due to an issue whereby the records aren’t correctly removed from the TVSeries database.

Use at your own risk.

  1. Make backup of your “TVSeriesDatabase4.db3” (always a good thing anyway)
  2. Download an SQLite tool, such as SQLite Browser.
  3. Make sure no instance of MP-TVSeries is running (otherwise bad things will happen), then File -> Open Database -> locate and open the “TVSeriesDatabase4.db3” file.
  4. Click on the “Execute SQL” tab, and copy and paste the following command:
    DELETE FROM local_episodes WHERE (SELECT COUNT(*) FROM local_series WHERE local_series.id = local_episodes.seriesid) = 0;
    and click on “Execute query” button.
  5. Save the database and close SQLite Browser
  6. Open MP-TVSeries config and re-run the import wizard, and everything should work again.

To see which episodes did not get properly deleted before you remove them, change “DELETE FROM” into “SELECT * FROM” and it will show you.

Published by

Adam

I am the person responsible for all this, that’s all you need to know.

One thought on “Mediaportal MP-TVSeries Re-Import Bugfix”

  1. Thank-you very much for this, the MP website wasnt much help but this looks to have sorted my problem. Cheers dude.

Leave a Reply

Your email address will not be published. Required fields are marked *