vSphere 4.1: Error Upgrading VMware Tools

As per http://www.vmadmin.info/2010/07/error-upgrading-vmware-tools.html; if you’re getting an “Error Upgrading VMware Tools” when trying to do an automated upgrade of VMware Tools from vCenter, or by clicking the “Upgrade” button on the VMware Tools GUI, you need to either:

  • Delete C:\WINDOWS\Temp\VMwareToolsUpgrader.exe for Windows guests, or
  • mkdir /tmp/vmware-root for Linux guests

Seems like yet another case where a bit of installer detection/handling logic would avoid these problems every occurring.